RFS/Etrading is Down

Incident Report for Zodia Markets Trading Platform

Resolved

This incident has been resolved.
Posted Aug 21, 2026 - 11:20 BST

Identified

Issue is at the Vendor side. We are working on it to resolve this issue as soon as possible.
Posted Aug 21, 2026 - 10:49 BST

Investigating

Please be informed that the E-Trading (RFS) service will be temporarily unavailable due to issues at the vendor side.

We are working on it to resolve this issue as soon as possible.
Posted Aug 21, 2026 - 10:48 BST
This incident affected: E-Trader.