E-trading - RFS trading is down

Incident Report for Zodia Markets Trading Platform

Resolved

Work around applied to bring up the RFS session.
RFS is back up and running.

Root cause investigation will be continued.
Posted Jun 03, 2025 - 10:02 BST

Investigating

We are currently investigating the issue.
Posted Jun 03, 2025 - 09:57 BST
This incident affected: E-Trader.