The issue has been resolved. Service has returned to normal, and we have confirmed that systems are operating as expected. We will continue to monitor performance and follow up on any further findings.
The disruption was caused by an outage on a downstream vendor system, which has now been remediated. FX pricing, crypto execution, and FX execution are all fully operational.
We appreciate your patience while we worked to restore full availability.
Posted Jul 21, 2026 - 11:04 BST
Update
Investigation is still ongoing regarding the FX execution issue on RFS. To clarify, FX pricing and all BTC/ETH trading remain completely unaffected and fully operational.
Posted Jul 21, 2026 - 09:14 BST
Update
Investigation is still ongoing regarding the FX execution issue on RFS. To clarify, FX pricing and all BTC/ETH trading remain completely unaffected and fully operational. Next update to follow shortly.
Posted Jul 21, 2026 - 06:06 BST
Investigating
We are continuing to investigate the issue affecting FX execution on our RFS. FX pricing remains unaffected, and BTC and ETH pairs are fully operational. Further updates to follow.