Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 09, 2026 - 08:00 BST
Update
We will be undergoing scheduled maintenance during this time.
Posted May 08, 2026 - 10:21 BST
Scheduled
Please be advised that we will be conducting scheduled Disaster Recovery (DR) testing in our Production environment this weekend. Maintenance Window: • Start: Saturday, May 9, 2026 – 08:00 UK Time • End: Saturday, May 9, 2026 – 20:00 UK Time (expected) Impact: All applications and related services will be unavailable during this period. We will provide updates through this channel should there be any changes to the schedule or if we encounter significant issues.
Posted May 08, 2026 - 10:19 BST
This scheduled maintenance affected: E-Trader, Settlement, OTC, and Customer Portal.