E-Trading - Is Down

Incident Report for Zodia Markets Trading Platform

Resolved

Our team has thoroughly investigated the root cause and implemented necessary measures to prevent recurrence.
Posted Jun 11, 2025 - 07:10 BST

Identified

Currently experiencing technical difficulties. Our dedicated team is working tirelessly to restore full functionality as quickly as possible. We appreciate your patience and understanding, and will keep you updated with any developments.
Posted Jun 11, 2025 - 07:01 BST
This incident affected: E-Trader.