E-Trading (RFS) service is unavailable currently.

Incident Report for Zodia Markets Trading Platform

Resolved

This incident has been resolved.
Posted Jan 19, 2026 - 05:16 GMT

Identified

Issue with the INFRA and it is fixed now.
Posted Jan 19, 2026 - 05:16 GMT

Investigating

RFS trading is currently unavailable. Our teams are actively working to restore the system and will provide updates as progress is made.
Posted Jan 19, 2026 - 04:58 GMT
This incident affected: E-Trader.